Service Product Update / EU-Prem

Scheduled for Apr 20, 06:00 - 07:00 CEST

Scheduled

Announcing a service release of the Cirrus platform, including bug fixes and minor improvements.

This release is planned for EU-Prem only and is being deployed outside the standard release window due to overlapping exams during the usual release cycles

Bugfixes
- Fixed an issue where the simplified blueprint caused problems when certain items were used in combination with a fixed form (CR-25567)
- Fixed an issue where anonymization os schedules could fail (CR-25565).
- Fixed an issue where the schedule window could not be set to exactly two years (CR-25504)

Improvements
- Improved QTI import functionality (CR-25600)

For more details please visit the Cirrus Release Notes page.

Time of release per hosted region:
EU Premium: 06:00 CEST (05:00/04:00 UTC)
Posted Apr 15, 2026 - 10:21 CEST
This scheduled maintenance affects: EU Premium Assessment Management (Dublin) (Scheduling (EU Premium), Marking (EU Premium), Authoring - Library/Assessments (EU Premium), Administration (EU Premium), Auxiliary - Services (EU Premium)) and EU Premium Candidate Delivery (Dublin) (Candidate Delivery incl Proctoring API (EU Premium), Single Sign-On SAML 2.0 / LTI (EU Premium), Invigilation (EU Premium)).